Device drivers

IXXAT VCI 4 driver

ST03A versions from V3.9 and higher only work with the IXXAT VCI 4 driver, which supports both the older IXXAT USB-to-CAN and the newer IXXAT USB-to-CAN V2 compact devices.

IXXAT VCI 3 driver and Windows 10 with Secure Boot

The IXXAT VCI 3 driver must not be installed on computers that use Windows 10 with Secure Boot enabled. For computers with activated Secure Boot please use ST03A V3.9 or higher with IXXAT VCI 4 driver.

IXXAT USB-to-CAN V2 compact

To be able to use IXXAT USB-to-CAN V2 compact with ST03A versions from V3.3.45 and higher please replace the IXXAT driver installed from the ST03A CD. For ST03A versions lower than V3.3.45 please first upgrade your Service Terminal version to a newer one to be able to use IXXAT USB-to-CAN V2 compact.

IXXAT devices and drivers used with ST03A versions

Supported device
driver versions
ST03A V2.4.07, V2.5.19, V2.6.14ST03A V2.7.34, V3.0.72, V3.1.24, V3.2.13ST03A V3.3.45, V3.4.31, V3.5.45, V3.6.43, V3.7.32, V3.8.01ST03A V3.9, V3.10
IXXAT USB-to-CAN (old)
2.162.183.4.1, 3.5.24.0.598.0
IXXAT USB-to-CAN V2 (new)(not supported)(not supported) 3.5.2 4.0.598.0

Softing CANpro USB

From 2014, Softing started the delivery of the CANpro USB interface generation which replaced the old CANusb interfaces.

To be able to use Softing CANpro USB with ST03A versions from V3.5.45 and higher please replace the Softing driver installed from the ST03A CD with the CAN Driver V5.17 as described below. For ST03A versions lower than V3.5.45 please first upgrade your Service Terminal version to a newer one to be able to use Softing CANpro USB.

To replace the old Softing driver with the Softing CAN V5.17 device driver:

  • Uninstall previous versions of Softing CANusb driver.
  • Download ST03AV3.6.43_drivers.zip , unzip and start CANDriversAndSoftware.exe to install the device driver (default settings can be applied).
  • Connect the CANusb adapter to the USB port and follow the appearing instructions.
  • Start ST03A.
  • Select the Tools > Options... menu item.
  • Choose the Devices node on the left side of the window.
  • Select Softing CANusb in the drop down list.
  • Click OK to close the Options dialog window.

Softing devices and drivers used with ST03A versions

Supported device driver versionsST03A V2.4.07, V2.5.19, V2.6.14, V2.7.34, V3.0.72, V3.1.24, V3.2.13ST03A V3.3.45, V3.4.31ST03A V3.5.45ST03A V3.6.43, V3.7.14, V3.7.18ST03A V3.7.31, V3.8.01, V3.9, V3.10
Softing CANusb (old)4.005.165.165.175.20
CANpro USB (new)(not supported)(not supported)5.165.175.20

Important: Please start at any standard (old) PC that has no problem recognizing the CANpro USB with its original boot block. Please also install the latest driver setup from the Softing website on that PC.

  • The setup may ask you to uninstall an earlier version of the setup. Please do so manually using Windows’ programs and features control panel and then install the new setup.
  • Now connect your CANpro USB device to this machine. It should be recognized then.
  • At this stage you can use the boot block update tool. The update instructions can be found within the ZIP file: CANpro_USB_bootblock_updateV1_05.pdf
  • This will bring the connected CANpro USB to the latest version 1.05 of the boot block .
  • Please install the new CAN driver setup also on your new PC. Now the updated CANpro USB should work fine.

Warning

Bootblock version problem

In ST03A versions V3.5.45 and higher CANPro could not work with USB 3.0 port since CANPro USB with Bootblock version of 1.00 is not compatible with these devices.

The solution is to download and install Bootblock 1.05 Updater (which can only be installed with the Softing CANUsb/Pro driver of 5.19 or later).